ADC Fails To Connect To ADM for Pooled Licensing

ADC Fails To Connect To ADM for Pooled Licensing

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Article ID: CTX310687

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Updated On:

Description

When trying to add the ADC to the ADM for Pooled Licensing, or CPU based licensing, or anything that uses ADM as the license server, you receive an errror.
Error might be "Unable to connect to licenseserver" or "Registration of device failed".

Resolution

  • On ADM, try restarting services by logging into CLI and issuing the following commands:
shell
/mps/masd restart
  • If you are using Citrix Cloud ADM, and are using Agents to handle the ADCs, you need to try running the commands on all ADM Agents.

Problem Cause

The licensing service on ADM could be down and needing restart.  If Citrix Cloud is being used for ADM, one of the ADM Agents will be a master and needs to be running for any other Agent to perform licensing tasks.

Additional Information

https://support.citrix.com/s/article/CTX691215-netscaler-adm-issues