XenApp Session Idle Timeout Does Not Apply at the Set Interval

XenApp Session Idle Timeout Does Not Apply at the Set Interval

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Article ID: CTX134756

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Updated On:

Description

The Session Idle Limit (Server idle timer interval) is set using Citrix Policies and appears to be successfully applied to the XenApp Server. However, the session idle timeout does not apply at the given interval. It was noticed that the session idle time interval was set to 6 minutes, but did not apply until an hour later.

Resolution

As the policy was applied to Remote Desktop Services it affects both ICA/RDP listening protocols. The use of Citrix IMA or Group policies to control the server idle timer interval is recommended.


Problem Cause

Checking the policies registry key reveals the MaxIdleSessionTimeout has been set correctly under ICA key but the time interval is not honored.
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICAPolicies
MaxIdleSessionTimeout 360000 (6 minutes)

After blocking the group policy inheritance on the XenApp OU, the ICA server idle timeout applied successfully. Further investigation into group policies applied to the server revealed that a Remote Desktop Services idle session limit was applied.
User-added image
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
MaxIdleTime 3600000 (1 hour)

Issue/Introduction

This article provides resolution when XenApp Session Idle Timeout does not apply at the set interval.

Additional Information

CTX127318 - How to Configure Idle and Disconnect Timeout Settings in XenApp 6.x
CTX133933 - XenApp 6.x Logon Sessions are Repeatedly Disabled
CTX134641 - Logon Mode of a XenApp 6.x Server Reverts to "Allowed"
CTX132634 - Case Study: ICA Disconnected Session Terminal Service Timeout Settings Not Working
CTX125139 - How to Modify ICA-TCP Listener with Remote Desktop Session Host Configuration for XenApp 6.x