Error Number 51 when Using an STA and ICA Client for Macintosh

Error Number 51 when Using an STA and ICA Client for Macintosh

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Article ID: CTX118082

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Updated On:

Description

When connecting to a Citrix Secure Gateway server, you experience one of the following errors:

From a 32-bit ICA client:

"The network connection to your application was interrupted"
Or
"Protocol Driver Error"

From a Macintosh client:

"Connection to Server “;40;STA……;ABF…..” failed
Error Number 51"

Resolution

Attempt to isolate and resolve the underlying network issue using general network troubleshooting techniques.

From the STA servers,

  1. Enable C:\Program Files\Citrix\System32\ctxsta.config to a log level of 3 using Notepad.

  2. Restart the XML service.


Problem Cause

The STA ticket has expired, cannot be found, or the connection to the Secure Gateway server from the client cannot be established.

Note: These errors can be reproduced when disabling the network interface card (NIC) on the Secure Gateway server, waiting for the client’s session reliability to timeout, modifying the STA ticket within the ICA file prior to connection, disabling the NIC on the client computer, and waiting for the session reliability timeout to expire.

Issue/Introduction

Error Number 51 when Using an STA and the ICA Client for Macintosh

Additional Information

CTX102594 - Error: Connection to server IP failed. Error: 51.

From the STA logs:

In the following example, the last two digits(33) of the ticket were removed before a reconnection attempt was made.

INFORMATION 2008/07/09:17:36:08 CSG1305 Request Ticket - Successful. 769DF279BE35FBAE15044B65A0805833 V4 CGPAddress = 10.12.34.175:2598:localhost:1494 Refreshable = false XData = <?xml version="1.0"?><!--DOCTYPE CtxConnInfoProtocol SYSTEM "CtxConnInfo.dtd"--><CtxConnInfo version="1.0"><ServerAddress>10.12.34.175:1494</ServerAddress><UserName>davidri</UserName><UserDomain>uofm</UserDomain>
<ApplicationName>notepad</ApplicationName><Protocol>ICA</Protocol></CtxConnInfo> ICAAddress = 10.12.34.175:1494

INFORMATION 2008/07/09:17:36:51 CSG1304 Request Data - Successful. 769DF279BE35FBAE15044B65A0805833 V4 CGPAddress = 10.12.34.175:2598:localhost:1494 Refreshable = false XData = <?xml version="1.0"?><!--DOCTYPE CtxConnInfoProtocol SYSTEM "CtxConnInfo.dtd"--><CtxConnInfo version="1.0"><ServerAddress>10.12.34.175:1494</ServerAddress><UserName>davidri</UserName><UserDomain>uofm</UserDomain>
<ApplicationName>notepad</ApplicationName><Protocol>ICA</Protocol></CtxConnInfo> ICAAddress = 10.12.34.175:1494

INFORMATION 2008/07/09:17:36:51 CSG1305 Request Ticket - Successful. 3822F243F4F79C8D9C647E9537CFBAD3 V4 Refreshable XData = <?xml version="1.0"?><!--DOCTYPE CtxConnInfoProtocol SYSTEM "CtxConnInfo.dtd"--><CtxConnInfo version="1.0"><ServerAddress>10.12.34.175:1494</ServerAddress><UserName>davidri</UserName><UserDomain>uofm</UserDomain>
<ApplicationName>notepad</ApplicationName><Protocol>ICA</Protocol></CtxConnInfo> ICAAddress = 10.12.34.175:1494 CGPAddress = 10.12.34.175:2598:localhost:1494

WARNING 2008/07/09:17:37:39 CSG1203 Request Data - Ticket not found. 769DF279BE35FBAE15044B65A08058

From the Secure Gateway logs:

Event Type: Information
Event Source: Secure Gateway
Event Category: TICKETING
Event ID: 271
Date: 7/9/2008
Time: 5:36:51 PM
User: N/A
Computer: FTLRDRINECSG
Description:
Request STA STA634D52A9253F to resolve ticket for client IP 10.12.34.171. (initial connection)

Event Type: Information
Event Source: Secure Gateway
Event Category: CGP
Event ID: 184
Date: 7/9/2008
Time: 5:36:51 PM
User: N/A
Computer: FTLRDRINECSG
Description:
Client IP [10.12.34.171:2604] with username [davidri@uofm] connected successfully to server [10.12.34.175:2598], resource [notepad] using protocol [ICA]. (initial connection)

Event Type: Information
Event Source: Secure Gateway
Event Category: CGP
Event ID: 185
Date: 7/9/2008
Time: 5:37:31 PM
User: N/A
Computer: FTLRDRINECSG
Description:
Client IP [10.12.34.171:2604] with username [davidri@uofm] successfully closed connection to server [10.12.34.175:2598], resource [notepad]. (manually disconnected the session)

Event Type: Information
Event Source: Secure Gateway
Event Category: TICKETING
Event ID: 271
Date: 7/9/2008
Time: 5:37:39 PM
User: N/A
Computer: FTLRDRINECSG
Description:
Request STA STA634D52A9253F to resolve ticket for client IP 10.12.34.171. (reconnection after modifying the ticket inside the ica file)

Event Type: Warning
Event Source: Secure Gateway
Event Category: TICKETING
Event ID: 235
Date: 7/9/2008
Time: 5:37:39 PM
User: N/A
Computer: FTLRDRINECSG
Description:
Service received error: invalid-ticket from STA STA634D52A9253F, client IP 10.12.34.171 connection dropped. (reconnection after modifying the ticket inside the ica file)

Event Type: Error
Event Source: Secure Gateway
Event Category: CGP
Event ID: 103
Date: 7/9/2008
Time: 5:37:39 PM
User: N/A
Computer: FTLRDRINECSG
Description:
Incoming Citrix Gateway Protocol downstream data could not be processed. (reconnection after modifying the ticket inside the ica file)