Citrix Virtual Apps and Desktops - ICA Launch failure, Connection was terminated by the server
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Article ID: CTX692996
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Updated On:
Description
When user tries to launch a session it fails with the error displayed in Citrix Workspace App: Connection was terminated by the server.
Citrix Director displays User Connection Failures; Reason: Unavailable Licenses
You can find the events in the Event Viewer on the Delivery Controller:
- Event ID: 1163
- Source: Citrix Broker Service
- No connection license available.
- Event ID: 505*
- Source : Citrix ConfigSync Service
- Command that failed: New-BrokerDesktopGroup
- Failure message: Unknown error occurred.
- *this event is not directly related to the launch attempt
If you check the License Server: Citrix Virtual Apps and Desktops licenses are there and the amount is sufficient.
If you check the Licensing node in Studio: Licenses are visible and the amount is sufficient. No errors displayed in Studio.
You can find the events in the Event Viewer on the VDA during launch attempt:
- Event ID: 1050
- Source: Citrix Desktop Service
- Connection validation failed on domain 'DOMAIN_NAME' for user 'USER_NAME' for reason 'Unlicensed'
Environment
The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.
Resolution
Make sure that you have required licenses installed on the License Server.
Disable App Protection on the affected desktop groups in order to allow users to launch the session (if you dont have required licenses / if app protection is not required anymore).
You can identify the affected desktop groups from PowerShell on the Delivery Controller:
Get-BrokerDesktopGroup | Select Name, Uid, AppProtectionKeyLoggingRequired, AppProtectionScreenCaptureRequired
If the values are set to TRUE - this means that AppProtection is enabled.
To disable:
Get-BrokerDesktopGroup -Uid X | Set-BrokerDesktopGroup -AppProtectionKeyLoggingRequired $false -AppProtectionScreenCaptureRequired $false
*where X is the Desktop Group's UID (you can get it from the first command above)
Problem Cause
No App Protection licenses available and AppProtectionKeyLoggingRequired, AppProtectionScreenCaptureRequired set to TRUE on the Desktop Group.
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