Support for ICA files in XenApp/XenDesktop Environment

Support for ICA files in XenApp/XenDesktop Environment

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Article ID: CTX200126

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Updated On:

Description

When users are connecting to XenApp or XenDesktop with an ICA file, there could occur a wide range of issues related to connection, load balancing, performance, cosmetic issues with an application and so on.

For users connecting with Citrix Receiver or Citrix Receiver in conjunction with StoreFront / Web Interface, issues are not observed.

Resolution

To avoid issues, use Citrix Receiver or use Citrix Receiver in conjunction with StoreFront / Web Interfaceto make all of your user connections.

ICA files are not supported by Citrix Technical Support. If you using an ICA file, Technical Support will have you to test the same scenario with the Citrix Receiver or the Citrix Receiver in conjunction with StoreFront / Web Interface

  • If the action is successful, it indicates that the problem lies with the ICA file.

  • If the action fails, then the support engineer would troubleshoot Citrix Receiver, but not the actual ICA file.

After the issue is fixed with Citrix Receiver, the issue would be considered resolved, even if the ICA file is still having issues.

Note: ICA files are not designed to work in production environments or scenarios (certain features do not work with ICA files and it could even cause the illusion that load balancing is not working correctly if direct connections are being made to certain servers). ICA files should only be used for troubleshooting and debugging issues.
ICA files are not managed by XenApp or XenDesktop, Citrix Technical Support does not update or maintain them. Citrix is not responsible for issues arising from their use as there are many uncontrolled factors that come into existence.

The following is a list of some of the common ICA file scenarios and their support status:

ScenarioSupported Status
ICA file created with a third- party utilityThis is not supported
ICA file created with Citrix Quick Launch UtilitySupported for testing or troubleshooting only
ICA file created with Citrix Quick Launch Utility and then manually modifiedThis is not supported
ICA file created with Citrix Quick Launch Utility and then rewritten by a third- party utilityThis is not supported
ICA file created manuallyThis is not supported
ICA file saved from Web Interface/StoreFront and used for connectionsThis is not supported
User has Citrix Receiver installed but is using an ICA file to launch applications or desktops This is not supported
ICA file created manually for XenDesktop High Availability (HA) modeThis is the only supported use for an ICA file and is a temporary solution

The only supported scenario for an ICA file is with XenDesktop HA mode. It is temporary and only to be used if XenDesktop Delivery Controller fails. But when XenDesktop is running without issues, users need to use Citrix Receiver or Citrix Receiver in conjunction with StoreFront / Web Interface for their connections. Use Citrix Receiver when connecting to a XenApp or XenDesktop environment.


Problem Cause

This issue is caused by using ICA files instead of Citrix Receiver.

Issue/Introduction

This article contains troubleshooting information on support for ICA files in XenApp/XenDesktop environment.

Additional Information

CTX122536 - Citrix Quick Launch Utility

CTX131547 - ICA File Rewrite for Citrix XenDesktop and XenApp Citrix Support Policy

CTX127392 - How to Create ICA Launch Files for High Availability Mode

Citrix Documentation - Ensure desktop and application access if Delivery Controllers fail (XenDesktop 7.x)