Unable to Launch Published Applications within XenApp Desktop

Unable to Launch Published Applications within XenApp Desktop

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Article ID: CTX134967

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Updated On:

Description

When users launch a published application in a published desktop on XenApp, the applications do not launch. However, launching the same applications outside the published desktop, works as expected. 

No errors are logged in the event viewer of the XenApp server or Web Interface server when applications are launched from within the published desktop. Also, other logs reveal no errors or problems on launching the applications.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Check the registry settings of the affected users to see if the following registry key is present: HKEY_Current_User\Software\Citrix\ICA Client\Engine\Lockdown Profiles
If this does not exist, copy from a working profile or download the attached template file.


Problem Cause

The Citrix Receiver client software installation is corrupt or some required registry settings are missing. 

Issue/Introduction

Unable to launch published applications from within a XenApp Published Desktop

Additional Information

CTX137494 -  Receiver Clean-up Utility
CTX804493 - Users Prompted to Download, Run, Open Launch.ica File, Instead of Launching Connection
CTX132875 - Citrix Receiver Error 2320