NetScaler - Error "Registration of device failed" when adding license server.

NetScaler - Error "Registration of device failed" when adding license server.

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Article ID: CTX693277

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Updated On:

Description

After recently deploying and registering a NetScaler Console (formerly ADM) Agent and trying to add it as a license server on a NetScaler device you get the error "Registration of device failed [Sending request to mgmtserver failed]".

Resolution

Wait at least 5 minutes after the agent is registered with the cloud before attempting to license a NetScaler using the agent.

If you wish to make sure that the agent is ready to receive license registration connections (TCP 27000), you can you the below from the agent shell prompt:

bash-3.2# sockstat | grep 27000 
root mas_clouda 1010 135 tcp4 *:27000 *:*

Once you get the output above, the process is ready to accept license server registration requests. 


Problem Cause

After registration and boot-up of the agent, there are several processes and checks that must take place before the agent is ready to accept incoming connections as a license server (TCP 27000). We suggest waiting at least 5 minutes after registration or subsequent bootup of the agent.

Additional requirements for the registration to be successful include:

  • A publicly signed SSL certificate is installed on the agent (or uncheck the 'Validate Certificate')
  • Enter the correct agent credentials
  • Have an existing Admin Profile created on NetScaler Console service and ensure that the name of that profile is entered in the 'Device Profile Name' field