WEM Agents are not listed in Console and failed to register

WEM Agents are not listed in Console and failed to register

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Article ID: CTX692787

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Updated On:

Description

WEM Agents are not listed in Console  and failed to register, 

Citrix WEM Agent Host Service Debug.log and Event Logs shows the below exception. 

ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.ServiceModel.Security.SecurityNegotiationException : The caller was not authenticated by the service.
ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.ServiceModel.FaultException : The request for security token could not be satisfied because authentication failed.

Resolution

When use Windows authentication or load balancing (requiring Windows authentication), use the following command to Create a service principal name(SPN)

setspn -U -S [SPN name] [accountname]

where [accountname] is the name of the service account that is being used for WEM infrastructure service Windows authentication.
[SPN name] is Norskale/BrokerService


Problem Cause

WEM Agent Authentication failed due to SPN Configuration.

Additional Information

Refer to Create a service principal name for more details