Topaz Signature Pad as COM Port Device Disappears after Logoff

Topaz Signature Pad as COM Port Device Disappears after Logoff

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Article ID: CTX692377

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Updated On:

Description

Topaz Signature will disappear after users log off on a kiosk workstation.

The environment contained:

Citrix Virtual Apps and Desktops version 2203 CUx (Desktop of Server VDA, any supported OS)
Citrix Workspace App 2402 CUx (Windows 10/Windows 11)

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

The solution consisted of multiple actions:

  1. The decision was made to only map the Topaz Signature device as a USB device instead of COM Port.
  2. Removal of the HSBtoCOM driver to ensure that only USB will be used.
  3. Since this was an environment with Workspace App 2402 CU1 and a VDA using CVAD-2203 CU5, we implemented USB device redirection rules on both ends:

VDA: Enable the policy allowing USB devices.

Client-Side Changes

POLICY PATH = Computer Configuration\Administrative Templates\Citrix Components\Citrix Workspace\Remoting client devices\Generic USB Remoting

Settings:

  1. USB Device Rules - State= Enabled - [Text Box] CONNECT: VID=06a8 PID=0043 # Topaz Signature Device
  2. Existing USB Devices - State = Enabled - [Drop Down Menu] Connect all available USB Devices
  3. New USB Devices  - State = Enabled - [Drop Down Menu] Connect all available USB Devices

Alternatively, we can use the Registry.

REGISTRY PATH (1) = HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Policies\Citrix\ICA Client\GenericUSB

Name: Device Rules
Type: REG_SZ
Data: CONNECT: VID=06a8 PID=0043 # Topaz Signature Device

REGISTRY PATH (2) = HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Policies\Citrix\ICA Client\USB
Name:
 Existing Devices
Type: REG_SZ
Data: Always

Name: New Devices
Type: REG_SZ
Data: Always

 

Please note, if your VDA version is 2402 or above, these settings can can just be deployed on the VDA and there is no need to apply the policy settings on the client if the client is also 2402 or above.

Problem Cause

Two factors were involved:

  1. The COM Port redirection via HSBtoCOM driver functioned as expected until some undetermined factor would cause the device to disconnect. With no real reconnect function within the application to reacquire the COM port device, the COM port mapping was lost.
  2. Because COM Port was disengaged, the Topaz device was no longer available as a COM port device, but was available as a USB device that could be manually mapped by the end-user. Its appearance, though, was as an "Unknown Device."

Once the HSBtoCOM Drivers were removed and the USB Device mapping containing the CONNECT verb was added, we provided relief:

  1. The USB would remained mapped and given the nature of USB, the connection is more resilient with better chances of recovery should something go awry.
  2. Because of the use of the CONNECT rule in combination with the policy settings mapping all new and existing devices (keep in mind, "all" means all of the devices on the Allow or CONNECT list), no only will the Topaz device connect, but it should also appear in Desktop Viewer or the Workspace App Device applet as "Topaz..." instead of "Unknown."

Issue/Introduction

USB Device Mapping, auto-connect USB Devices

Additional Information

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/usb#usb-support

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/2402-ltsr/generic-usb-devices