"Check for Available Renewals" may show error banner "citrixservices.citrix.com is unreachable"

"Check for Available Renewals" may show error banner "citrixservices.citrix.com is unreachable"

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Article ID: CTX691468

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Updated On:

Description

When user clicks "Check for Available Renewals" button in Citrix License Server Console, error banner "citrixservices.citrix.com is unreachable. The server might be offline or there might be Internet, Proxy, or Firewall issues. " may appear. Actually, the affected license server is able to reach out to citrixservices.citrix.com over port 443 through network connectivity utility, like Microsoft Test-NetConnection.

Resolution

Increase the ctxslsboc.exe running timeout by the following steps

  • Add <TimeLimit>180</TimeLimit> to <Configurations>...</Configurations> section in "C:\Program Files (x86)\Citrix\Licensing\WebServicesForLicensing\SimpleLicenseServiceConfig.xml".
  • Restart "Citrix Web Services for Licensing"
  • Note: you may change 180 sec to another desired value depending on customer's environment

Problem Cause

Citrix ctxslsboc.exe reached the default 60 sec timeout while processing the license renewal request and reply, which resulted in the "citrixservices.citrix.com is unreachable" error message. Depending on the Citrix license files count installed in the license server, the default 60 sec timeout may not be enough.

Issue/Introduction

The article describes a configuration issue regarding Citrix License Server "Check for Available Renewals" feature