Citrix Cloud MFA: Incorrect Code Error

Citrix Cloud MFA: Incorrect Code Error

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Article ID: CTX691338

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Updated On:

Description

When the code is entered from the authenticator App, Citrix Identity Admin receives an error "Incorrect code, please try again".

 


Instructions

Note : 

  • Ensure the Authenticator App is the one used for Time-based One Time Password

  • The device where the app is installed, date and time should be correct.

  • To ensure the date and time is accurate, use an internet time website. Alternatively if anyone else/colleague is able to  authenticate use the same date and time.

If the user is trying to enroll their authenticator app using Google Authenticator and is still running into the invalid code, follow the below steps (within the Authenticator App) : 

    1. Click Settings.
    2. Click "Time correction for codes".
    3. Click "Sync Now" and then try again.
    4. If the above troubleshooting steps does not resolve, Uninstall and reinstall the Authenticator App or Try to Install an authenticator other than what you currently have. E.g., (Citrix SSO, Google Authenticator, Okta, Microsoft Authenticator etc.,) 
    5. For all other Multifactor authenticator related issues, refer to Citrix Multifactor Authentication Troubleshooting.

 

Additional Information

Problem Cause: 

  • Incorrect Date and Time

  • If a device is - 90 seconds and + 60 seconds off as per https://time.gov, the token will not validate successfully. To check have the Admin go to time.gov on their mobile/desktop where the authenticator app is installed and verify. 
    At that point they should change the time on the device. Time setting on mobile device should be changed from automatic to set time.