Storefront - Event ID 3005 - The request queue limit of the session is exceeded

Storefront - Event ID 3005 - The request queue limit of the session is exceeded

book

Article ID: CTX678005

calendar_today

Updated On:

Description

When a user attempts to enumerate using the StoreWeb URL in a browser, not all icons are not enumerated. This can also occasionally result in enumeration failure and an error stating "Cannot complete your request" during enumeration. 

On the Storefront server, Windows Event Viewer > Applications and Services Logs > Citrix Delivery Services shows an unhandled exception error Event ID 3005 for w3wp.exe with account name: IIS APPPOOL\Citrix Receiver for Web

Resolution

WARNING: Please back up the web.config file to a safe location before editing any entries.

Find the following entry <appSettings> in the web.config file, and add the values as follows:

<appSettings>
<add key="aspnet:RequestQueueLimitPerSession" value="2147483647"/>
</appSettings>

After an IIS reset, attempt to login again and observe the event viewer logs ensure there is not another 3005 event.


Problem Cause

This occurs because the default ASP buffer per session limit is being exceeded in IIS.

 

Issue/Introduction

When users enumerate in StoreWeb, an event ID 3005 occurs in Citrix Delivery Services event logs.

Additional Information

Related Microsoft Article - https://learn.microsoft.com/en-us/dotnet/framework/migration-guide/retargeting/4.6.2-4.7#throttle-concurrent-requests-per-session