Unable to add store to Citrix Workspace App for Windows when Forcepoint agent is installed

Unable to add store to Citrix Workspace App for Windows when Forcepoint agent is installed

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Article ID: CTX676797

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Updated On:

Description

When adding a StoreFront store to Citrix Workspace App for Windows, the Google multi-factor authentication page does not load correctly if Forcepoint agent is installed. The authentication form only partially loads. Without Forcepoint agent, the problem disappears. 

Resolution

By default the Citrix Workspace App for Windows uses Internet Explorer WebView for authentication, which is not working with the Forcepoint agent is installed. To resolve the issue, change Citrix Workspace App to use Microsoft Edge WebView2 using a one of the options below:

1. Using Group Policy Object:

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/authentication.html#using-gpo 

2. Using client registry key:

Path: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\AuthManager

Create new string value named: EdgeChromiumEnabled

Set the new string value data to: true

3. Using Citrix Cloud with on prem StoreFront:

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/authentication.html#using-global-app-config-service


Problem Cause

Forcepoint is preventing the authentication page from loading correctly when using Internet Explorer WebView which Citrix Workspace App for Windows uses by default.