"Failed to launch application" with Citrix Workspace App for Chrome OS version 2402.

"Failed to launch application" with Citrix Workspace App for Chrome OS version 2402.

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Article ID: CTX630301

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Updated On:

Description

Users encounter the "Failed to launch application" error message when attempting to start a desktop session using Citrix Workspace App for Chrome OS version 2402.
This behavior is observed when initiating sessions from a delivery group that contains non-English characters while the Service Continuity feature is enabled.

Resolution

Option 1:

Disable Service Continuity feature
https://docs.citrix.com/en-us/citrix-workspace-app-for-chrome/session-experience#configuration

Option 2:

Use the browser to download ICA and then open it with the client app to launch the session.

Option 3:

Use backup Citrix Workspace App

Steps to deploy Citrix Workspace app via Google Admin Console for managed users: (Taken from the configuration section of https://community.citrix.com/tech-zone/build/tech-papers/deploying-cwa-for-chromebook-using-google-workspace)

  1. Sign in to your Google Admin console (https://admin.google.com) using an administrator account. Select Apps & extension, then select Users & browsers.
  2. In the Admin console, go to Menu. Select Devices
  3. Select Chrome devices.
  4. Select Apps & extension, then select Users & browsers.
  5. To apply the setting to all devices, leave the top organizational unit selected. Otherwise, select a child organizational unit.
  6. To add Citrix Workspace app.
  • Click + Add.
  • Select Add the Chrome app or extension by ID.
  • Enter the Extension ID for Citrix Workspace app. Click Save
  • Backup Citrix Workspace has extension ID 'anjihnbmjbbpofafpmklejenkgnjfcdi'
For BYO users :
  1. Please refer  https://docs.citrix.com/en-us/citrix-workspace-app-for-chrome/deploy.html#to-access-the-backup-build

Problem Cause

Citrix Engineering is currently investigating.