SecureMail 24.2 for iOS unable to connect to exchange server

SecureMail 24.2 for iOS unable to connect to exchange server

book

Article ID: CTX616971

calendar_today

Updated On:

Description

When a user on iOS updates their installed version of SecureMail to 24.2, it no longer syncs with on-prem exchange server.

Error in SecureMail logs as follows: "Secure Mail: The connection to the server timed out. Please try again in a few minutes."

Resolution

Update the configuration of SecureMail to MAM-SDK mode

Problem Cause

SecureMail is configured in LegacyMDX mode.
The option to select MAM-SDK mode vs LegacyMDX mode was introduced in 2021.  LegacyMDX mode has been deprecated since July 2023.

Refer to https://docs.citrix.com/en-us/citrix-secure-mail/whats-new.html
 

Issue/Introduction

Update SecureMail to use MAM-SDK mode, not Legacy-MDX mode

Additional Information

Additional information about the MAM SDK, and how it has replaced the MDX toolkit / app-wrapping can be found in the following docs pages
https://docs.citrix.com/en-us/mdx-toolkit/mam-sdk-overview.html
https://docs.citrix.com/en-us/citrix-endpoint-management/whats-new/removed-features.html#deprecations-and-removals
https://developer-docs.citrix.com/en-us/mobile-application-integration/mam-sdk-for-ios-and-ipads.html
https://docs.citrix.com/en-us/mdx-toolkit/overview.html