Citrix End User Experience Monitoring service fails to start on the VDA

Citrix End User Experience Monitoring service fails to start on the VDA

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Article ID: CTX587578

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Updated On:

Description

Citrix End User Experience Monitoring service fails to start.
When you try to start the service manually you get the error: service started and then stopped. 

CDF trace from the VDA shows the event:
[SemsController,NotMetricRelated] Failed to start with exception: System.Security.SecurityException: Requested registry access is not allowed.

Process Monitor shows the ACCESS DENIED status:

  • Process: SemsService.exe   
  • Operation: RegOpenKey        
  • Path: HKLM\SOFTWARE\WOW6432Node\citrix\Euem\LoggedEvents        
  • Status: ACCESS DENIED

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Modify the registry key permission and make sure LOCAL SERVICE has Full Control.
Registry location: HKLM\SOFTWARE\WOW6432Node\citrix\Euem\LoggedEvents
 

Problem Cause

Incorrect registry key permissions.
LOCAL SERVICE does not have Read/Write access to HKLM\SOFTWARE\WOW6432Node\citrix\Euem\LoggedEvents