Workspace App for Windows appears for AllAccount although only one store is configured

Workspace App for Windows appears for AllAccount although only one store is configured

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Article ID: CTX586297

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Updated On:

Description

Citrix Workspace App for Windows appears for all accounts although with just one store configuration.

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Workspace App should appear like this if only one store is configured.

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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

  1. Disable/update policy which removes following registry
    • HKCU\SOFTWARE\Citrix\Receiver\SR\Store\<serviceRecordId>
    • HKCU\SOFTWARE\Citrix\Dazzle\CurrentAccount

Problem Cause

1. Check if there is any policy to delete following registry from endpoint PC.
HKCU\SOFTWARE\Citrix\Receiver\SR\Store\<serviceRecordId>

If above registry is deleted by any policy, Workspace app changes the value of following registry to AllAccount, Workspace App appears accordingly.
HKCU\SOFTWARE\Citrix\Dazzle\CurrentAccount

2. Check if there is any policy configured to update following registry value to AllAccount.
HKCU\SOFTWARE\Citrix\Dazzle\CurrentAccount