The ICA file will be downloaded when launching resources in browser

The ICA file will be downloaded when launching resources in browser

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Article ID: CTX585036

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Updated On:

Description

The ICA file may be downloaded when launching the resource from a browser.
 

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

  1. Clear your browser's cache and cookies, then log back into Storefront for Web.
    1. Open Chrome.
    2. At the top right, click More
    3. Click More Tools Clear browsing data.
    4. At the top, choose a time range. To delete everything, select All Time.
    5. Next to "Cookies and other site data" and "Cached images and files," check the boxes.
    6. Click Clear data.
  2. Reset your browser and log in again.
    1. Open Chrome.
    2. At the top right, select More More and then Settings.
    3. Select Reset settings and then Restore settings to their original defaults and then Reset settings.

Note:
Always backup the data prior to making any changes and test those changes before implementation.
 

Problem Cause

locally installed Citrix Workspace App was not detected.
 

Additional Information

Enhanced ICA file security on Citrix Workspace app for Windows
https://www.citrix.com/blogs/2021/06/17/enhanced-ica-file-security-on-citrix-workspace-app-for-windows