Removing maintenance mode from hosting connection fails (after certificate thumbprint update)

Removing maintenance mode from hosting connection fails (after certificate thumbprint update)

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Article ID: CTX584653

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Updated On:

Description

  1. After the SSL certificate is updated on vCenter, updated the cert SSL thumbprint on for DaaS using remote powershell SDK
  2. We put the Hosting Conneciton in maintenance mode to achieve above.
  3. Updated the certificates on Trusted People store of Cloud Connectors.
  4. This causes all the catalogs from this hosting connection to go in "PowerState Unknown" state.
  5. Even for the powered on and registered VDAs, users cannot launch apps/desktops.

Environment

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Resolution

  1. Verify if Username is in the format - domain\username
  2. If it is, change the format to username@domain.com with same password on the existing hosting connection.
  3. Issue should be resolved.

Problem Cause

On vSphere side, SSO was disabled due to security requirements and only LDAP logins were allowed.

Issue/Introduction

If SSO is disabled for vSphere logins, the Citrix service account must be updated as username@domain.com format with correct password on Hosting Connection.

Additional Information

Disable and Enable vCenter Single Sign-On Users

Enabling Active Directory / LDAP / LDAPS