Cloud Connector - Citrix ConfigSync Service error event ID "517"

Cloud Connector - Citrix ConfigSync Service error event ID "517"

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Article ID: CTX584599

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Updated On:

Description

In Cloud Connector Server, the below Error Event (ID 517) is logged.
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Source: Citrix ConfigSync Service

Event ID: 517

Description:
There was a problem communicating with the primary Broker. Failed to get minimal Broker configuration.

Error details:
There was a problem communicating with the primary Broker.
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Resolution

If Citrix Config Sync Service event ID "503" or "504" is logged soon after error "517", which indicates Citrix Config Sync Service is back to normal soon, this should be temporary network issue.
Please verify Cloud Connector server has proper network connectivity first. 
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503: The Citrix Config Sync Service received an updated configuration. This event occurs each time an updated configuration is received from Citrix Cloud. It indicates the start of the synchronization process.
504: The Citrix Config Sync Service imported an updated configuration. The configuration import completed successfully.
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If error ID "517" is outputted consistently for a long time, please collect the following logs in Cloud Connector servers and contact Citrix Technical Support for further investigation.
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  • Windows Application and System event logs (both evtx and csv).
  • Connector CDF traces in "C:\Logs\CDF"
  • The results of Connector Connectivity Check Utility tool.

Cloud Connector Connectivity Check Utility
https://support.citrix.com/article/CTX260337/cloud-connector-connectivity-check-utility
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Problem Cause

Possible Cause:
The Cloud Connector machine is experiencing intermittent network connectivity issues