Citrix Server Idle Timer Policy does not take effect for Server VDA

Citrix Server Idle Timer Policy does not take effect for Server VDA

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Article ID: CTX584206

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Updated On:

Description

  • Citrix Server Idle Timer Policy does not take effect for All Server VDA
  • Configure Server Idle Timer Policy Interval on 2203CU1 DDC for all the Server VDA , but after reach time limit , there is no expected Idle windows pop up 

Resolution

  • Disable Citrix ICA Keep Alives Policy from "Send ICA Keep alive message" to default disable status
  • Disable Microsoft Idle timer policy if they already have it configured in Computer Configuration/User configuration >Administrative Templates >Windows Components > Remote Desktop Services > Remote Desktop Session Host >Session Time Limits
     

Problem Cause

  • Citrix ICA Keep Alives Policy configure as "Send ICA Keep alive message" in Citrix policy. 
This setting enables or disables sending ICA keep-alive messages periodically.
By default, keep-alive messages are not sent.
Enabling this setting prevents broken connections from being disconnected. If the server detects no activity, this setting prevents Remote Desktop Services (RDS) from disconnecting the session.
  • Same type policy interrupt. Microsoft Idle timer policy if they already configure in Computer Configuration/User configuration >Administrative Templates >Windows Components > Remote Desktop Services > Remote Desktop Session Host >Session Time Limits

Additional Information

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/keep-alive-policy-settings.html