Failed to delete VM from Citrix Web Studio

Failed to delete VM from Citrix Web Studio

book

Article ID: CTX583821

calendar_today

Updated On:

Description

Failed to delete VM from Citrix Web Studio.

The virtual machine S-xxxxxxxxxxxxx was deleted.

MachineFailure : S-xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Internal error:
Failed to delete virtual machine

ErrorID : Citrix.MachineCreation.DataModel.MachineCreationDiagnosticException

TaskErrorInformation : Citrix.MachineCreation.DataModel.MachineCreationDiagnosticException: Deletion of virtual machine failed.

 

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

1. Stop the VM in question in the Azure Portal and verify that it is in the "Stopped (deallocated)" state.

2. Execute the following to remove the VM from the catalog:
 > Remove-BrokerMachine -MachineName xxx\xxx

3. Remove the VM from the Azure Portal.

4. Remove the AD account associated with the VM from AD.

Note:

Please replace xxx with the actual machine name.

Please confirm in the test environment before executing this command.


 

Problem Cause

The virtual machine in question contains the Japanese character 'ー',

When the Cloud DDC Azure plugin configures VMId, the Japanese character 'ー' is incorrectly recognized as '?

When the Cloud DDC Azure plugin configures the VMId, Azure returns a 'BadRequest'.