Error: "There are no apps or desktops available for you at this time" after logon StoreFront

Error: "There are no apps or desktops available for you at this time" after logon StoreFront

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Article ID: CTX582632

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Updated On:

Description

Multiple zones are configured within a single site.
Primary zone and Satellite zone both contain one Delivery Controller and one Storefront for redundancy.

If the Delivery Controller in Satellite zone fails, the whole environment is still working well.

But if the Delivery Controller in Primary zone fails, the error message "There are no apps or desktops available for you at this time." is shown after logging into StoreFront.

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Resolution

In the Primary zone, install at least two Controllers for redundancy.

Problem Cause

As prerequisites, the Primary zone should have at least two Controllers for redundancy.
If the Primary zone contains only one Delivery Controller and this Controller fails, this issue may occur.

Additional Information

Zones
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/manage-deployment/zones.html