Unable to launch resources or Studio - connection between broker service and database has been lost

Unable to launch resources or Studio - connection between broker service and database has been lost

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Article ID: CTX580404

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Updated On:

Description

Users unable to launch resources such as published applications and desktops. 
Administrators unable to use Studio to manage environment.

When checking event viewer logs on the DDC, we see event 1201 warning: 


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When accessing the SQL Database, below error is see: 
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Environment

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Resolution

There are various way to resolve this issue
  1. Reboot the DDC to clear the stuck transaction.
  2. Configure "Database Recovery Model" to "Simple". See Citrix support article for guidance - https://support.citrix.com/article/CTX126916/xendesktop-database-transaction-log-growing-excessively
  3. Backup the transaction log more frequently to free the inactive portion. Please check with your SQL administrator to do this.
  4. Monitor transaction log utilization using sys.dm_db_log_space_usage . See Microsoft article for more information - https://learn.microsoft.com/en-us/sql/relational-databases/system-dynamic-management-views/sys-dm-db-log-space-usage-transact-sql?view=sql-server-2017

Problem Cause

Stuck transaction resulted in transaction log growth which filled up the storage and can result in outage.

Issue/Introduction

stuck transaction filled up SQL tempDB