book
Article ID: CTX580404
calendar_today
Updated On:
Description
Users unable to launch resources such as published applications and desktops.
Administrators unable to use Studio to manage environment.
When checking event viewer logs on the DDC, we see event 1201 warning:

When accessing the SQL Database, below error is see:

Environment
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Resolution
There are various way to resolve this issue
- Reboot the DDC to clear the stuck transaction.
- Configure "Database Recovery Model" to "Simple". See Citrix support article for guidance - https://support.citrix.com/article/CTX126916/xendesktop-database-transaction-log-growing-excessively
- Backup the transaction log more frequently to free the inactive portion. Please check with your SQL administrator to do this.
- Monitor transaction log utilization using sys.dm_db_log_space_usage . See Microsoft article for more information - https://learn.microsoft.com/en-us/sql/relational-databases/system-dynamic-management-views/sys-dm-db-log-space-usage-transact-sql?view=sql-server-2017
Problem Cause
Stuck transaction resulted in transaction log growth which filled up the storage and can result in outage.
Issue/Introduction
stuck transaction filled up SQL tempDB