Can't view license usage on Studio - Error "Citrix license server unavailable"
book
Article ID: CTX580395
calendar_today
Updated On:
Description
Can't view license usage on Studio - "Citrix License server unavailable."
When accessing the License Manager web console, error Unsupported Protocol with the message "The client and server don't support a common ssl protocol version or cipher suite" appears.
Resolution
Follow the below steps to enable only TLS1.2 for TCP port 8083 used by the Citrix Web Services for Licensing service.
- Run notepad as an administrator and open the following Apache configuration file "C:\Program Files (x86)\Citrix\Licensing\WebServicesForLicensing\Apache\conf\extra\httpd-ssl.conf"
- Find the line that starts with "SSLProtocol" and put a # at the front to comment it out to save it for future reference.
- Add the following line above the line you just commented out: SSLProtocol -All +TLSv1.2
- Restart the "Citrix Web Services for Licensing" service to take effect.
Problem Cause
Citrix Web Services for Licensing was wrongly configured to accept only TLSv1.
Was this article helpful?
thumb_up
Yes
thumb_down
No