Workspace error "Unable to add account with the given server URL"

Workspace error "Unable to add account with the given server URL"

book

Article ID: CTX580263

calendar_today

Updated On:

Description

After adding Gateway URL on Windows Workspace, we can see below error:
--------
Unable to add account with the given server URL. Ensure that it is correct or enter your email address
--------
image.png

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

  1. Request a new server certificate file from Public or Private Certificate Authority. Make sure that the common name of the new server certificate should match the FQDN of the Gateway URL.
  2. Install the new server certificate on NetScaler, then bind the new server certificate under Citrix gateway virtual server.
  3. Make sure the windows client can trust the new server certificate.

Problem Cause

The common name of the server certificate configured in Gateway virtual server doesn't match with the accessing FQDN, which break the certificate trust in Workspace client.
According to the network trace captured on NetScaler, Workspace client sent TLS Alert(Level: Fatal, Description: Certificate Unknown) to NetScaler during establishing SSL session.
image.png
 

Issue/Introduction

After adding gateway URL on Windows Workspace, we can see below error: -------- Unable to add account with the given server URL. Ensure that it is correct or enter your email address --------