Cannot decompress firmware package with error "invalid compressed data--format violated"

Cannot decompress firmware package with error "invalid compressed data--format violated"

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Article ID: CTX579936

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Updated On:

Description

Running command "tar -xvzf build-xx-xx_nc_64.tgz" in NetScaler shell to decompress firmware package, but it fails with error "invalid compressed data--format violated".

Environment

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Resolution

1. Download NetScaler firmware package from NetScaler downloads .

2. Re-upload firmware package to NetScaler by using any file transferring method such as WinSCP. Refer to step 6 ~7 in edoc. WinSCP can be downloaded from WinSCP offical website.

3. To verify uploaded fimware package' SHA-256 checksum to confirm the package is not corrupted by running following command in NetScaler shell.

For example:
sha256 build-13.1.-49.13_nc_64.tgz

SHA256 (build-13.1.-49.13_nc_64.tgz) = 71b53a51f2e773f7e23deb66102441504e0c52e70712f3ece137689fb224080e
Compare the checksums value output is same with checksums value on NetScaler downloads , each NetScaler Firmware package contains an SHA-256 checksums as follows.

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Problem Cause

The firmware package is corrupted when uploaded to NetScaler. 

Issue/Introduction

Firmware is tampered or corrupted and unabled to be decompressed

Additional Information

https://support.citrix.com/article/CTX137749/how-to-verify-the-integrity-of-the-netscaler-firmware-file