Mouse cursor invisible when hovering over text based apps in Citrix session

Mouse cursor invisible when hovering over text based apps in Citrix session

book

Article ID: CTX579816

calendar_today

Updated On:

Description

  • ADM based Endpoints/Laptops
  • Mouse invisible when hovering over text based apps
  • Mouse cursor not appearing with AMD integrated graphics inside the Citrix Sessions

Resolution

It is an AMD graphics driver issue, which has been reported several times with several version of AMD drivers.
  • Findings from Citrix about these types of issue - 
The problem is caused by MPO (Multiplane Overlay) support issue of AMD GPU. Some related information about it can be found at:

 

  • Workaround from Citrix: 

Disable GPU or Disable MPO
 

  • Possible fix which essentially disabled MPO:

Issue can be addressed by disabling MPO with below registry setting:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Dwm]

"OverlayTestMode"=dword:00000005

 

  • Another version of AMD drivers that explicitly mention fixing on Citrix sessions: 

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-23-4-1

 

  • Other possibilities: 
  • Technically, you can disable AMD graphics driver updates completely.
  • If the endpoints are managed, you can simply plan the Display Driver updates through your endpoint management software/application.
  • If the endpoints are unmanaged, you will need to manually set GPO or Registry settings to disable AMD driver updates.

Problem Cause

The problem is caused by MPO (Multiplane Overlay) support issue of AMD GPU.

Additional Information

https://learn.microsoft.com/en-us/windows-hardware/drivers/display/multiplane-overlay-support 
https://support.google.com/docs/thread/188363640/cursor-turning-white-in-google-docs?hl=en 
https://community.amd.com/t5/drivers-software/invisible-mouse-pointer-citrix-workspace/m-p/560141/highlight/true