Issue with webcams displaying a green screen when using "Media Foundation" encoding.
book
Article ID: CTX576074
calendar_today
Updated On:
Description
Using "Media Foundation" encoding causes green screen issues with webcams.
Environment
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Resolution
Change the encoding of the webcam from "Media Foundation" to "DirectShow" by following these steps
Select WebEx > Settings > Video > Advanced > Video Capture: [Microsoft DirectShow] > Save.

Problem Cause
The FFmpeg API used by the new version of CVAD is updated.
It is not compatible with WebEx's "Media Foundation" encoding.
Additional Information
FFmpeg
https://ffmpeg.org/doxygen/3.4/deprecated.html
Was this article helpful?
thumb_up
Yes
thumb_down
No