Safari browser loading Web page failure when accessing HTTP2 LB Virtual Server

Safari browser loading Web page failure when accessing HTTP2 LB Virtual Server

book

Article ID: CTX576073

calendar_today

Updated On:

Description

If ADM Web Insight Client Side Management (CSM) is enabled, only the Safari browser is unable to open Web page via HTTP2 enabled LB Virtual Server. 
If ADM Web Insight Client Side Management (CSM) is disabled, issue does not occur.
While other browsers (i.e. Firefox, Chrome) work fine regardless of the ADM Web insight Client Side Management (CSM) configuration.
 

Resolution

Workaround for HTTP2 LB Virtual Server - To disable Client Side Management (CSM) of Web insight on ADM.
  1. Navigate to Infrastructure>Instances>Citrix ADC
  2. Check the instance and Select Configure Analytics from Select Action dropdown button
  3. Check the Virtual Server, Click Enable Analytics or Edit Analytics
  4. Uncheck the Client Side Management under Web Insight
  5. Click Save

Problem Cause

Safari browser is incompatible with NetScaler ADM Client Side Management feature.
With Client Side Management enabled on NetScaler ADM for the HTTP2 virtual server, NetScaler captures load time and render time metrics for HTML pages through HTML JavaScript injection. However, the JavaScript prevents Safari to handle HTTP2 protocol in Safari browser.