NetScaler EPA scan fails on Mac OS Client

NetScaler EPA scan fails on Mac OS Client

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Article ID: CTX570696

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Description

EPA scan fails on Mac OS client only, libs folder is missing in ~/Library/Application Support/Citrix.

Note: Where the ~ symbol indicates the relevant Mac OS user's home directory path.

Resolution

Solution 1: Copy MacLibs.zip from NetScaler firmware file and upload to /var/netscaler/gui/epa/scripts/mac.

Solution 2: Download and upgrade EPA library files on NetScaler, please refer to EPA Libraries Download for more details.

Problem Cause

You will see the following error in epaplugin.log, which means NetScaler returns 403 forbidden when client attempts to download EPA library files. (The location of epaplugin.log is "~/Library/Application Support/Citrix/EPAPlugin")

Couldn't download library files from NS. Code =  403

This is because MacLibs.zip is missing in /var/netscaler/gui/epa/scripts/mac in NetScaler.

Issue/Introduction

EPA scan fails on Mac OS device because libs folder is missing.

Additional Information

https://www.citrix.com/downloads/citrix-gateway/epa-libraries/epa-libraries-for-netscaler-gateway.html