Cannot launch applications nor desktops at the second try in Citrix Workspace App

Cannot launch applications nor desktops at the second try in Citrix Workspace App

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Article ID: CTX568728

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Updated On:

Description

After adding the store to Workspace App, users can launch applications successfully for the first time.
But when users exit the Workspace app and reopen it, they fail to launch applications on the second try.

Error "Your apps are not available at this time" appears.

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Resolution

  • To fix the error, you must re-add the store.
  • The Logon Type in StoreFront must be consistent with the Authentication Method set on NetScaler Gateway.
In this case, LDAP is configured as the Authentication Method on NetScaler but "Domain and Security token" is improperly configured on StoreFront as the Logon Type.
 
  1. From the StoreFront Studio navigate to Manage Citrix Gateways -> Edit Gateway -> Authentication Settings -> Logon type.
  2. Select Domain as Logon Type
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Problem Cause

Logon Type configured on StoreFront is inconsistent with the Authentication Method set on NetScaler.