Joining Server Group failed with error "Exception attempting to authorize, TCP error code 10060"
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Article ID: CTX567559
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Updated On:
Description
Joining the Server Group failed with the following errors.
Studio UI:
Please refer to the Windows Event Log on the Authorizer details.

Windows Event Log:
Citrix Cluster Join Service,1,(2201),"Join failed. Exception attempting to authorize. Could not connect to net.tcp://storefrontname/Citrix/ClusterService. The connection attempt lasted for a time span of 00:00:21.0021089. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond IPofstorefrontserver:808."
Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
Allow all Citrix StoreFront features to pass through Windows firewall:
- Go to Control Panel > System and Security > Windows Defender FireWall > Allowed Apps
- Make sure that all the Citrix StoreFront features are allowed under Domain, Private, and Public.

Problem Cause
Windows firewall has wrongly blocked necessary communication among StoreFront servers via port 808.
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