Windows Workspace Authentication Error "incorrect user name or password" via NetScaler Gateway

Windows Workspace Authentication Error "incorrect user name or password" via NetScaler Gateway

book

Article ID: CTX566171

calendar_today

Updated On:

Description

When using Windows workspace, after input username, password and passcode, error prompt "incorrect username or password"(two-factor basic authentication). And can't access Storefront resource list. While access same Gateway with Web Browser is working fine.
 

Resolution

If two-factor basic authentication , the Session profile for Receiver Self-Service policy needs set to SECONDARY in  Credential Index checkbox.
  1. Navigate to Citrix Gateway>>Policies>>Session>>Session Profiles
  2. Select Session profile for Receiver Self-Service, Click Edit button
  3. Navigate to Client Experience tab , search Credential Index under Single Sign-on to Web Applications checkbox.
  4. Check override and set SECONDARY in Credential Index checkbox.
  5. Click OK to save change.

NOTE: 2 factors classic authentication configuration guide in Gateway for Workspace(Receiver) , please click here .
 

Problem Cause

Incorrect configuration for Credential index under Single Sign-on to Web Applications checkbox