Receiver for Web gets Logged Out with "Your logon has expired" before Session Timeout is Reached

Receiver for Web gets Logged Out with "Your logon has expired" before Session Timeout is Reached

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Article ID: CTX564347

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Updated On:

Description

Session Timeout in StoreFront has been set to 3 days by admin, but the Receiver for Web page will always be logged out the next day.
When trying to launch the desktop/app the next day, the error "Your logon has expired. Please log on again to continue" will appear and they're required to log on again.
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Environment

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Resolution

Disable Application Pool recycling in IIS.

  1. Open IIS, click Application Pool -> Citrix Receiver for Web -> Recycling
  2. Uncheck Specific time(s), Then click Next -> Finish

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     3. Open CMD with administrator privilege, and run command "iisreset".

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Problem Cause

Starting from IIS 7, Application pool restarts by default every 24 hours at 2:00 am, this feature is called recycling. 

As Web receiver is a web application, it is also restarted at 2:00 am, which will cause StoreFront web session to be logged out the next day.

This can be disabled but the restarts are there to ensure that resource utilization is reset.

For more information please refer to:
https://learn.microsoft.com/en-us/iis/configuration/system.applicationhost/applicationpools/add/recycling/