Unable to Start Desktop with FAS Enabled and Assert UPN Error Event 102 on FAS Server

Unable to Start Desktop with FAS Enabled and Assert UPN Error Event 102 on FAS Server

book

Article ID: CTX564342

calendar_today

Updated On:

Description

Errors on FAS's event viewer
Source: Citrix.Authentication.FederatedAuthenticationService
Event ID: 102
[S102] Server [xxxx] failed to assert UPN [xxx@xxxx] (Exception: The user name or password is incorrect.
image.png
 

 

Resolution

Disclaimer: information displayed in screenshots are Citrix test server data.

Add "User logon name" properties in AD Account
  1. Open Active Directory Users and Computers console
  2. Search the User account and open its Properties
  3. Fillup the User Logon name and make sure UPN is correct
image.png

image.png
 

Problem Cause

cannot find UPN name in AD account properties,lack of User logon name
image.png