User Cannot Reconnect to Server VDA Sporadic with "Remote Desktop Service is Currently Busy" Error

User Cannot Reconnect to Server VDA Sporadic with "Remote Desktop Service is Currently Busy" Error

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Article ID: CTX564280

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Updated On:

Description

User Cannot Reconnect to Server VDA Sporadic with "The task you are trying to do can't be completed because Remote Desktop Service is currently busy. Please try again in a few minutes."
Other users should still be able to sign in.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Add registry on the VDA to extend wait time:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI

Value Name: UsermodeLoadedWaitMS
Type: REG_DWORD
Data (decimal): 30000 (Example 30000milliseconds = 30seconds)

Problem Cause

Waiting for winlogon timed out

 

Issue/Introduction

Add registry to extend wait time to solve Remote Desktop Service is currently busy

Additional Information

https://support.citrix.com/article/CTX217482/users-are-unable-to-launch-applications-errorthe-task-you-are-trying-to-do-cant-be-completed-because-remote-desktop-services-is-currently-busy