Windows login prompt while connecting to Remote PC in SSO mode

Windows login prompt while connecting to Remote PC in SSO mode

book

Article ID: CTX560795

calendar_today

Updated On:

Description

When Remote PC is used, You get challenged for credentials even when SSO is used

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

The Remote Desktop Services “Prompt for Password” policy prevents Single Sign-on to the Virtual Delivery Agent.

Check registry key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services.
If fPromptForPassword = 1 then you need to change it to 0.

Note : Make sure that the GPO is not set in Computer Configuration | Policies | Administrative Templates | Windows Components | Remote Desktop Services | Remote Desktop Session Host | Security | Always prompt for password upon connection. In which case, you need to update the GPO.


Problem Cause

Starting with the Jasper release, the Microsoft Remote Desktop Services setting is being used on Workstation to provide an identical function as the former XA "Always Prompt For Password".

 

Additional Information

https://www.carlstalhood.com/citrix-virtual-delivery-agent-vda-2203-ltsr/