Noticeable Delay of Adding User Store in CWA for Mac Residing within a Restricted Intranet

Noticeable Delay of Adding User Store in CWA for Mac Residing within a Restricted Intranet

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Article ID: CTX560286

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Updated On:

Description

In an isolated intranet that can't connect to the Internet, CWA for Mac users may notice an obvious delay of around 30 seconds during certain operations e.g. adding a store, user authentication, and launching published resources.

Environment

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Resolution

At the moment, there is no method to disable the query of app configuration from GACS in Mac Workspace App.
The options below can be leveraged if the stated symptom is noticed in a restricted client network for MacOS users.

Option 1:
Whitelist the US Citrix Cloud URL in the network to enable querying of app configuration.

Option 2:
Add discovery.cem.cloud.us as 127.0.0.1 in Mac OS local hosts file located in the /private/etc/hosts directory.
 

Problem Cause

CWA for Mac now will connect to Citrix US Cloud https://discovery.cem.cloud.us/ to do a query and download of app configuration in Global App Config Service (GACS).
If the specific URL is not reachable then the request will timeout in around 30 seconds, which leads to the noticeable delay user is facing now in the restricted Intranet.

CWA log snippet:
05-26-2023 | 14:53:39.665 | 611 | 61999 | CtxAppConfigQueryOperation.m |  102 | -[CtxAppConfigQueryOperation didCompleteUrlTaskWithData:response:error:] | CtxAppConfigService |    LL_ERROR | URL request for SettingsQuery failed with error: Error Domain=NSURLErrorDomain Code=-1004 "could not connect to server" UserInfo={_kCFStreamErrorCodeKey=61, NSUnderlyingError=0x60000161e4f0 {Error Domain=kCFErrorDomainCFNetwork Code=-1004 "(null)" UserInfo={_NSURLErrorNWPathKey=satisfied (Path is satisfied), interface: en0[802.11], ipv4, dns, _kCFStreamErrorCodeKey=61, _kCFStreamErrorDomainKey=1}}, _NSURLErrorFailingURLSessionTaskErrorKey=LocalDataTask <A0DA8178-3B02-41A7-A073-4019DFCD17DB>.<4>, _NSURLErrorRelatedURLSessionTaskErrorKey=(
    "LocalDataTask <A0DA8178-3B02-41A7-A073-4019DFCD17DB>.<4>"
), NSLocalizedDescription=could not connect to server。, NSErrorFailingURLStringKey=https://discovery.cem.cloud.us/ads/root/url/aHR0cHM6Ly92ZGkudmdjLnZnY3NlcnYuY29tLmNuOjQ0Mw/product/workspace/os/macos , NSErrorFailingURLKey=https://discovery.cem.cloud.us/ads/root/url/aHR0cHM6Ly92ZGkudmdjLnZnY3NlcnYuY29tLmNuOjQ0Mw/product/workspace/os/macos , _kCFStreamErrorDomainKey=1}

Additional Information

The stated query workflow is in-line with Workspace App for Windows.
In Windows OS, we provided a solution for disabling the query workflow via registry modification in CTX477071.