The Desktop Cannot Be Displayed in Full ICA Window with Gray Border when Reconnecting to Remote PC
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Article ID: CTX552074
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Updated On:
Description
When user launch the ICA session, the session desktop cannot be displayed in full ICA window, with a gray border.
It is displayed normally after the Remote PC first reboot. However, if user try to reconnect or relogin after logout, the gray border appears again.

Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Add the follow registry on the Remote PC:
- Path: HKLM\Software\Citrix\Graphics\AdapterMerits
- Key: CitrixIDD Type: DWORD Value: 3
- Key: CitrixIDDMax Type: DWORD Value: 3
Problem Cause
GPU vendor adapters are not applicable.
Issue/Introduction
Choose the proper display adapter to solve the ICA display issue.
Additional Information
https://support.citrix.com/article/CTX237608/display-adapter-priority-and-monitor-creation-in-citrix-sessions
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