Re-Enter the controller Address - Failed to validate the Central Confg Service location

Re-Enter the controller Address - Failed to validate the Central Confg Service location

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Article ID: CTX549308

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Updated On:

Description

Reenter controller address error studio. " Failed to validate the central Configuration service location"

Error:  Reenter the controller address or enter a new address, on the delivery controller. 
Reason: Database could not be contacted.

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Resolution

Proceed to check the following to identify and/or resolve the issue: 
  1. Check for recent changes on the Environment.
  2. Try disabling the Antivirus on DDC and SQL server.
  3. Open powershell in admin mode and run Get-BrokerController or Get-BrokerSite and see if you are able get the result of the cmdlets.
  4. Check if logged in as a Domain administrator on the DDC server.
  5. Restart the SQL Service on the SQL server.
  6. Check the connection on Port 1433 from DDC to SQL server and Vice Versa.
  7. Run the following command in PowerShell as an Administrator tnc <destination server FQDN> -p 1433
    • If you get the TNC result as False, Ask the customer to open the port 1433 between DDC and SQL server. Otherwise Try by adding the 1433 ports in Windows defender firewall as a INBOUND and OUTBOUND rule on both the servers.
  8. Check if the error details contains CheckGlobalAccess message in the inner exception section.
  9. Verify the Das.Administrators table for number administrators added under Citrix Studio
  • Open SQL Management studio >> Connect to SQL server instance 
  • Expand Databases>> [SiteDatabase] >>  Tables >> DAS.Administrators
  • Right click on DAS.Administrators > Select Top 1000 Rows.
This will display the SIDs of the Administrator objects configured for the Site.
  1. Ensure there are no stale SID records in the Das.Administrators table
  2. Validate the SID's to resolve the name using the below powershell cmdlet
$objSID = New-Object System.Security.Principal.SecurityIdentifier `
    ("<SID in question>")
$objUser = $objSID.Translate( [System.Security.Principal.NTAccount])
$objUser.Value
  1. If any of the SID is not able to translate the SID to username, remove that perticular entry from DAS.Administrators table by executing the below SQL query in SQL CMD Mode
  2. Delete From DAS.Administrators Where ID = <ID number of the SID>
On Delivery controller Close the Citrix Studio and clear the MMC cache for Citrix Studio and re-launch the Citrix Studio and monitor the behavior.

Problem Cause

Database could not be contacted.