Unable to Sign into Citrix Cloud Administrator Portal using Azure AD Error AADSTS50105

Unable to Sign into Citrix Cloud Administrator Portal using Azure AD Error AADSTS50105

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Article ID: CTX495504

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Updated On:

Description

When logging into the Citrix Cloud Administrator Portal using the Citrix.Cloud.com/go/ address, the Administrator receives the error message AADSTS50105: Your Administrator has configured the application [APPLICATION NAME] ("APPLICATION UUID") to block users unless they are specifically granted ('assigned') access to the application. The signed in user 'ADMINISTRATOR EMAIL' is blocked because they are not a direct member of a group with access, nor had access directly assigned by an Administator. Please contact your administrator to assign access to this application. 

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Resolution

The Azure Administrator will need to ensure that the requesting authentication belongs to the App Registration within Azure. The App Registration ID can be found in the context of the error, and should be looked at to determine if the assigned Group contains the requesting Administrator, or if the Administrator is assigned explicitly. If the Administrators are assigned, check the Permissions blade to identify if the Administrator has 'Access' permissions

Problem Cause

This error means one of two things:
  1. The Administrator does not belong to the App Registration or in the Group assigned to the App Registration on Azure
  2. The permission levels for the Administrators have been modified and no longer have Default Access or 'Access' permissions