Black Screen on Logon to Windows 11 Multi-Session

Black Screen on Logon to Windows 11 Multi-Session

book

Article ID: CTX492509

calendar_today

Updated On:

Description

Users frequently see a black screen on published desktop that doesn't load after waiting on Windows 11 Multi-Session VDA. 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

  1. Deleting the following registry values helped resolved the issue:
    • HKLM\SYSTEM\CurrentControlSet\Services\vbdenum\Parameters\DeviceList\IndirectDisplayAdapter
    • HKLM\SYSTEM\CurrentControlSet\Enum\PCI\Ven_5853&DEV_1003 

Problem Cause

Most likely due to a failing uninstallation of previously installed servervdi, which caused the desktop OS VDA graphics driver settings to remain in the registry, which causes the user mode graphics driver to load at machine startup time, and this graphics driver instance causes conflict with a per session graphics driver instance.