[CGS] Citrix Cloud Workspace launching Desktop via CSG is stuck at "connecting" and failed

[CGS] Citrix Cloud Workspace launching Desktop via CSG is stuck at "connecting" and failed

book

Article ID: CTX492435

calendar_today

Updated On:

Description

Citrix Cloud Workspace launching Desktop/App via CSG (Citrix Gateway Service) is stuck at "connecting" and failed.

In the Netscaler Gateway Service logs, seen in ns.log:

Event "Application launch failed. Connect command sent to Controller."

Resolution

  1. Check the zone setting of the VDA resource and correct wrong or invalid setting.
    1. Under the DaaS > Manage > Machine Catalog [ Under Details section of highlighted Catalog - Check the Zone Configured/Displayed ]
    2. Under DaaS > Manage > Zones [ Confirm that the Cloud Connectors & Machine Catalog of the VDAs you are trying to launch are all under the same Zone ]

Problem Cause

STA (Secure Ticket Authority) service returns an invalid RL (Resource Location) to CSG (Citrix Gateway Service) and CGS can not find the right Cloud Connector with in the appropriate RL to establish the connection to the backend server.

Additional Information

https://docs.citrix.com/en-us/citrix-daas/manage-deployment/zones.html