book
Article ID: CTX492213
calendar_today
Updated On:
Description
When trying to install Cloud Connector software on a windows server, after selecting the customer ID on the pop up window, users receive an error message saying: "The current user does not have the necessary access type. Please ensure that the user has full administrator privileges".
Administrator is a full administrator within Citrix Cloud.

Resolution
Fix: cwcconnector.exe version 6.71.x.x or higher will contain a fix for this issue which is yet to be released.
Workaround: Until cwcconnector.exe version 6.71.x.x or higher is released and assigned to the tenant, Please use the following workaround.
For a new installation of Citrix Cloud Connector, Use previous cwcconnector.exe version 6.57.0.28833
https://downloads.cloud.com/root/connector/cwcconnector.exe with the silent installation method.
The installation process will automatically upgrade 6.57.0.28833 to 6.70.0.30785.
Problem Cause
This is a current known issue when installing cloud connector software.
A new Citrix Cloud Connector installation using cwcconnector.exe version 6.70.0.30785 results in the following error on the tenant where customerid is not in lowercase. In cwcconnector.exe version 6.70.0.30785, there was a change introduced to perform the validation for Full Administrator upfront and this validation is failing on the tenant where customerid is not in lowercase.
Issue/Introduction
Unable to install connector. User does not have necessary access type