CVAD 2203 CU1 - VDA installation failure - error code 1603

CVAD 2203 CU1 - VDA installation failure - error code 1603

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Article ID: CTX491899

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Updated On:

Description

Failure to install VDA  ending with error code 1603

When lookin into the MSI logs, we have following error =

MultimediaVideoTs_x64.msi

SOFTWARE RESTRICTION POLICY: Verifying package --> 'D:\MigrationVDA2203CU2\MigrationVDA2203CU2\x64\Virtual Desktop Components\TS\MultimediaVideoTs_x64.msi' against software restriction policy
MSI (s) (AC:08) [15:29:33:947]: SOFTWARE RESTRICTION POLICY: D:\MigrationVDA2203CU2\MigrationVDA2203CU2\x64\Virtual Desktop Components\TS\MultimediaVideoTs_x64.msi has a digital signature
MSI (s) (AC:08) [15:29:34:261]: SOFTWARE RESTRICTION POLICY: D:\MigrationVDA2203CU2\MigrationVDA2203CU2\x64\Virtual Desktop Components\TS\MultimediaVideoTs_x64.msi is permitted to run at the 'unrestricted' authorization level.
MSI (s) (AC:08) [15:29:34:261]: MSCOREE not loaded loading copy from system32

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Sometimes the easiest way to fix these issues is to run the VDA Cleanup Utility.

If this does not work, follow the steps below : 
1-uninstall Workspace and  VDA software on the server
2-rename (with .old) the folder listed below :

C:\Program Files\Citrix
C:\Program Files\Common Files\Citrix
C:\Program Files (x86)\Citrix
C:\ProgramData\Citrix
C:\Users\<MyUserID>\AppData\Local\Citrix

And the following registry entries :

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix

After that, the installation of the VDA is now in success.
 

Problem Cause

Possible corruption on old registry key or data files