Workspace App for Mac - Known Issue - March 23rd 2023

Workspace App for Mac - Known Issue - March 23rd 2023

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Article ID: CTX491310

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Updated On:

Description

When using Citrix Workspace App for Mac, users may receive the following error(s):

- Unable to communicate with Authentication Manager service

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- The Store doesn't exist. Please retry or contact support.

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- Citrix Workspace cannot connect to the server. Check your network connection.

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- Could not detect the specified account. The server might be invalid or may be unavailable at this time. Make sure the URL is correct and check your network connection.

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- For users who can launch sessions, some capabilities such as inbound screen sharing during Microsoft Teams call may not work when Microsoft Teams Optimization is enabled

Resolution

Option 1 (recommended):
Citrix recommends customers to download and manually install fix for this issue 24.02.x, available at: 
https://www.citrix.com/downloads/workspace-app/mac/workspace-app-for-mac-latest.html

Option 2: 
Customers using 2211 to download and manually install the fix for this issue 22.11.1.60, available at:
https://www.citrix.com/downloads/workspace-app/legacy-receiver-for-mac/workspace-app-for-mac-2211.html

*Note: Auto Update from older versions to new versions will not work in this scenario. Manual installation instructions provided in product documentation
 


Problem Cause

The issue was result of expiration of a code signing certificate used by Citrix Workspace App.