VDA installation wizard and process disappears during install

VDA installation wizard and process disappears during install

book

Article ID: CTX490733

calendar_today

Updated On:

Description

When attempting to launch VDA installation, the install process simply disappears.

Event logs on VDA shows an MSI error and an "Apps" error.

  • "Windows installer installed the product... citrix universal print server installation success or error status: 0"

image.png

 

  • "activation of app Microsoft.Windows.Appprep.chxapp can't be activated by the built-in Administrator"

image.png



Issue occurred despite running the VDA cleanup utility. 

 
  • Attempted installation from the CMD line:
    • Registering sendexperiencemetrics=0 in registry...
    • Unknown error FailedMedia

image.png

 

Resolution

Checked UAC to address the error referencing "Built-in Administrator".  Opened "GPedit":

  1. Navigate to Windows Settings > Security Settings > Local Policy > Security Options.
  2. Locate and open the User Account Control: Admin Approval Mode for the Built-in Administrator Account.
  3. Under Local Security Setting tab select Enable.
  4. Click on Apply and OK to save your changes.


This eliminated  the "Apps" error in event viewer, however install still fails.


Checked ProgramData and renamed the file: C:\ProgramData\Citrix\XendesktopSetup\CitrixVirtualDesktopAgent.xml


Attempted install again and this worked, VDA installed without any issues. 


 

Problem Cause

Incorrect local configuration to perform action with Built-in Administrator
Old and corrupted information in the C:\ProgramData\Citrix\XendesktopSetup\CitrixVirtualDesktopAgent.xml file.

Issue/Introduction

Issues when attempting to install VDA. VDA installation wizard and process disappears during install