Cannot complete request when accessing HTTPS Storefront URL
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Article ID: CTX483274
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Updated On:
Description
When users access the storefront webpage they get an error saying "cannot complete request" on the detect workspace app / receiver web page.

Resolution
New SSL cert needs to be created.
When creating SSL certs, make sure the common name used on the certficate matches the base URL of your storefront server.
For more information on creating SSL certs for Storefront servers. please visit - https://support.citrix.com/article/CTX200292/how-to-generate-and-install-an-ssl-certificate-on-a-storefront-server-for-https-connections
Problem Cause
The SSL cert that was created did not have the base URL set in the common name when the cert was created.
We confirmed this by going to the storefront web browser and checked the cert that users were getting when the get to the storefront web page.
Here we could see the Issued to filed did not reflect the base URL of the storefront server.
Issue/Introduction
When users access the storefront webpage they get an error saying "cannot complete request" on the detect workspace app / receiver web page.
Additional Information
https://support.citrix.com/article/CTX200292/how-to-generate-and-install-an-ssl-certificate-on-a-storefront-server-for-https-connections
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