book
Article ID: CTX482378
calendar_today
Updated On:
Description
Post upgrading the Citrix Workspace App to 2302 the applications are not launching.
Error message while we launch the application. "The digital signature on wfica32.exe is invalid (error: 1116)"
Environment
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Resolution
- Navigate to C:\Program Files (x86)\Citrix\ICA Client
- Right click on wfica32.exe and select Properties > Digital signature > View certificate > Certificate Path
- Verify the Certificate is trusted
- Compare the non-working and working scenario to find out differences
- Non Working scenario certificate path:

- Working scenario certificate path:
- Download and install the Root certificate =
- DigiCert Trusted Root G4
- DigiCert Trusted G4 Code Signing RSA4096 SHA384 2021 CA1
- Install DigiCert Trusted Root G4 into Trusted Root Certification Authorities in Machine store
Problem Cause
Root certificate missing in C:\Program Files (x86)\Citrix\ICA Client > Properties > Digital signature > View certificate > Certificate Path
Additional Information
https://www.digicert.com/kb/digicert-root-certificates.htm